User talk:PsiPro

From The Aquarium Wiki
Jump to: navigation, search

That fish table in Category:Cichlids (African), are you able to add in the latin name as well as common please? I tried but don't have the magic coding touch!! --Cat 13:29, 21 August 2015 (UTC)

-Thank you!! Looks way better. Is it possible to do the same for the American Cichlid page? I quite like this list haha! --Cat 10:33, 25 August 2015 (UTC)
I got a 503 error posting the above comment, stupid errors!! --Cat 10:36, 25 August 2015 (UTC)
Also, was looking at possible photos to use as a backing for the fish species box for Brackish, maybe this one? Mangroves on Wikipedia --Cat 16:09, 25 August 2015 (UTC)
That looks good to me. --Brian 16:47, 25 August 2015 (UTC)
How do you do the backing thing? Is it a specially sized image you make? --Cat 09:09, 26 August 2015 (UTC)
Yep, so first step is to trim it up how ever you feel looks best. You can see the FW background is here: File:Freshwater_background.jpg. Once you upload it there, you add an entry to MediaWiki:Common.css. :) If you trim it up I'll do the CSS stuff. --Brian 16:42, 27 August 2015 (UTC)
Think I've added it right??! Not sure if the colours need tweaking further, only have Irfanview to work with here! --Cat 12:17, 28 August 2015 (UTC)

Hiya! All good over here :) been doing a lot more over on VC than here, sorry about that! --Cat 13:43, 23 May 2015 (UTC)

Also got this when posting the message there! Error 503 Service Unavailable Service Unavailable Guru Meditation: XID: 1396112646 --Cat 13:45, 23 May 2015 (UTC)

Strangely enough I get more errors on this wiki than the VC wiki, almost never on VC, but a lot on here when doing edits. Odd!
I did see your little one! Congrats both! All good here --Cat 09:49, 3 June 2015 (UTC)

Hi, I have a doubt about editing a page or not doing it. http://www.theaquariumwiki.com/Corydoras_adolfoi picture is wrong. The catfish in that photo is a C. Duplicareus. C. Adolfoi don't have a thick line like C. Duplicaerus have. Also C. Duplicaerus are stockier than C. Adolfoi (this ones usually grows 1cm more in length than C. Duplicaerus. Check http://www.planetcatfish.com/catelog/_species.php?species_id=1 to see the difference. Usually LFS sell C. Duplicaerus as Adolfoi because they are quite alike (also I'll be uploading new C. Duplicaerus photos soon) --Bittersweet 16:23, 9 February 2012 (CST)

Sorry for the delay in my response, by all means make the changes. As long as it is done with good intent we are very much a do first, then ask permission :) Thank you for your work. If you need any help don't hesitate to ask. --Brian 06:53, 14 February 2012 (CST)
Also keep in-mind that many people will assume they were sold whatever the pet-store has. Since those fish are so similar a good identification section is important so people can get to the correct species page. --Brian 06:55, 14 February 2012 (CST)

What are the different ways to copyright my image? --ZooTycoonMaster

I'd prefer that it's to be only used on this site. --ZooTycoonMaster


Read the Site Help - Images and media page, it has details.

If the image is copyright to you then that automatically means it can be only used on the hosting site. But there is no harm in stating this in the text below it. :-)

--Quatermass 09:52, 27 July 2009 (UTC)


Twitter extension[edit]

Heya! I don't suppose Wikipedia's invented any kind of twitter-esque plugin? One that shows regular tweets is there? For my toy site. --Cat 19:25, 11 August 2009 (UTC)


Hi Cat,

Wikipedia uses these extensions - MediaWiki. Big List here: Matrix

They appear to have this - SendToTwitter

"Sends a twitter update to twitter every time an article is updated on your wiki."

--Quatermass 20:53, 11 August 2009 (UTC)


oooo now that sounds clever! it would absolutely make my twitter a bit chaos but sounds ideal! would you be able to pop this on? thank you! --Cat 07:20, 12 August 2009 (UTC)


On where?

--Quatermass 08:29, 12 August 2009 (UTC)


On my toy wiki that Brian helped me set up ^__^ --Cat 10:22, 12 August 2009 (UTC)

Ah right. Sure I could. You'd have to give me FTP access though. Brian is on holiday atm. Best switch to emailing me with the info. --Quatermass 15:59, 12 August 2009 (UTC)


I've forgotten the FTP access >_< it can wait until Brian is back. --Cat 18:08, 12 August 2009 (UTC)


catcatxx@gmail.com --Cat 18:16, 12 August 2009 (UTC)


Heya! I don't use VC for email so you don't need to worry about that. Let me know when you're doing the move! --Cat 12:09, 14 September 2009 (UTC)


As soon as I can remember where the domain lives now to change the nameservers I'll change them eep! I've just tried uploading a pic, that worked fine, but the gallery tag thing doesn't work. See here: http://www.vinyl-creep.net/Nosego#Images what happened there then?? --Cat 19:40, 20 September 2009 (UTC)


Any luck with the images? VC is based around images...not that I'm impatient or anything haha! --Cat 11:06, 22 September 2009 (UTC)


Eep, there seems to be a problem with images here too, newly uploaded ones just don't show. VC is still not working either. --Cat 10:53, 23 September 2009 (UTC) yay! all works now! thank you! --Cat 23:00, 23 September 2009 (UTC)


bleh, now I've lost VC, I presume it's to do with the nameserver which I can't remember how to change as there was a bit of the ol' confusion when I switching from my old site to the new wiki and now I don't know where to go to change the nameservers and GAH! --Cat 22:01, 26 September 2009 (UTC)


that's the thing, I know who the host is, but as I didn't use them as a server any more I think I asked them to cancel the account I started and merge it with another I already had - renewing worked ok BUT I can't find it when I log in and their support centre hasn't replied to me in a week...GRRRRRRR--Cat 12:16, 27 September 2009 (UTC)


Yeh, I got the email but it didn't really tell me anything new, it's just Netkeepers being useless and incommunicable! *shakes fist at Canada* I'll try and email them with this dnsadmin email and see what happens. --Cat 10:01, 28 September 2009 (UTC)


Just wondering why both sites are a bit unpredictable with loading at the moment?? Sometimes they just won't load at all :( --Cat 11:57, 11 October 2009 (UTC)

Big Ideas[edit]

So I just got an Iphone (clearly late judging by everyone else on the tube in the morning, all staring at their iphones) and wondered if it would ever be possible to have this site available as an App? Wikipedia does have a free Iphone App now. It would definitely be handy when in fish stores! It obviously doesn't need to be as complex as this site but I have no idea how Apps are made anyway. Thoughts? --Cat 12:37, 17 November 2009 (UTC)


haha cool! --Cat 21:37, 17 November 2009 (UTC)


SVG Images[edit]

Hi Brian, I posted this to Quarter master talk page as well...but after looking around you might be able to answer this as well:

I'm trying to SVG images to render correctly on my wiki but am having problems. Looks like you have been able to do it. Can you offer any suggestions? In particular, I'm trying to get images for template:ambox to work and some state flags.

Thanks

Kevin

Hey kevin, its been awhile since I set this up, I think it was some issue with imagemagik. If i remember I'll let you know. --Brian 01:51, 16 January 2010 (UTC)


Yeah, if you think of it please drop me a line. The svgs I'm trying to get to work correctly are from template:ambox...which it looks like you guys have imported from wikipedia as well. Also trying to get some state flags to work. Wikipedia uses librsvg as an svg renderer so I was looking into that but if it can be done with imagemagik that might be a little easier. It's probably something in local settings...

Also having some slowness issues...I think that might be the webhost. It looks like you've got a webhosting company, any suggestions?

thanks for your help!

Kevin

Hey there, I looked over my LocalSettings.php and I recently added $wgSVGConverter = "rsvg"; to the configuration, I would look at that. As for the webhosting, I used to have a webhosting company but I sold it and moved all my personal sites to a VPS from rackspace http://www.rackspacecloud.com/. So far its been great, and the speed is nice. I have a 512 VPS, so it cost ~$20/month for the server + more for the bandwidth. If your able to manage your own box its great choice. Whats your wiki btw? P.S. when I was with hostgator.com I felt that did a great job, but its been 4 years since I have been on true shared hosting. --Brian 23:58, 17 January 2010 (UTC)


Hmmm, ok I'll take a look at that. I was already on that track and had that line in my local settings but did not add $wgSVGConverterPath yet and download the library.

Send me your email and I'll send you a link. It's still a work in progress so don't want to post public links just yet.

Kevin

arjesins gmail.com (you can fill in the blank :) )

Wikia[edit]

Also, from the first entry on Q talk page it looks like wikia made an unsolicited offer take over your content. Was there anything special you did to prevent them from doing this? If you don't want to post a response to that here you can rrest. Any tips on how to prevent that would be appreciated.


Kevin

Like Q said, we just said no. Someone eventually set it up by them selves but there isn't any content. http://aquarium.wikia.com/wiki/Aquarium_Wiki IMHO there is only a benefit to wikia is easy access to additional editors. Editors other then Cat and Q are few and far between in general. --Brian 01:56, 16 January 2010 (UTC)

Peculiar Error[edit]

I just created Centropyge argi‎, but now keep getting an internal server error when I try and go to the page. It may fix itself, but argh!--Cat 11:53, 15 June 2010 (UTC)

I've seen it on and off as well, the problem is that nothing is appearing in the error log, so I can't track it down. Normally refreshing fixes the error. --Brian 17:57, 15 June 2010 (UTC)
They are definitely getting more frequent and refreshing isn't always fixing it now (maybe cache related? I don't know!). Getting annoying when adding pages, had to delete a page I hadn't properly created yesterday as I kept getting internal server errors when I tried to post it. argh! --Cat 12:38, 6 July 2010 (UTC)
Another weird Database error which says "A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

(SQL query hidden)

from within function "MediaWikiBagOStuff::_doquery". MySQL returned error "1030: Got error 134 from storage engine (localhost)". --Cat 21:39, 19 July 2010 (UTC)

Here's a database error example: Suckers
  • Looks fine here. :-) --Quatermass 16:01, 21 July 2010 (UTC)
Hmm, works here too, will try it again on the work computer tomorrow. Just keep getting random internal server errors and database crashes everywhere! --Cat 20:13, 21 July 2010 (UTC)
I fixed it earlier, every now and then the DB table crashes that stores the processed pages. Its a side effect of the amount of traffic and the table driver being a poorer driver. Converting to the new driver is a headache and I have looked into it. As for the "500 Internal Server Errors", I see them, but they are not creating any log entries so it is essentially impossible to track since they are reliable not reproducible. If you can reproduce them regularly it will be easier to track down.

test edit

Uploading the same image with different sizes[edit]

Hi Brian,

Thanks for your tips on "no need to upload the same image with different sizes"! When I clicked on the "Show preview" button, the outcome didn't show a shrinked image, so I thought it was necessary to upload a 200 pixel wide image. Now I know, thanks! --Jimchan 00:41, 21 October 2010 (EDT)

Being "bold"[edit]

I added a link to a phrase in the welcome template, and wrote a draft of Responsible fishkeeping. I hope writing such a piece is not overstepping my bounds, and hope to see it massaged into something everyone can agree on. Huw Powell 23:23, 4 March 2011 (EST)

It looks good to me, I'm sure we will do some editing later on. --Brian 14:48, 6 March 2011 (EST)

Clean up[edit]

I've got to get back to work now. I've unpicked a couple of pages and deleted where I can. Started at the bottom and worked up but some need some serious unravelling! Have reverted all Templates that were messed with, so those shouldn't need touching again, would recommend switching the pages to protected though. Cannot get rid of the spam on the top of this page though Procambarus alleni‎, don't know how they've done it! Makes me want to cry. I want to stab hot pokers through the eyes of anyone whoever spams/triggers spambots. --Cat 08:45, 21 April 2011 (EDT)

ARGH I can't work out the bulk undo, am trying to fix Caridina cf. cantonensis --Cat 08:56, 21 April 2011 (EDT)
In light of this carnage, while it may be harsh, is it possible to prevent unregistered users making edits on the site? The decent edits we get are from registered users anyway! --Cat 08:59, 21 April 2011 (EDT)
I think that is trivial in MW, yes. There's also some trick to do bulk reverts by one editor, but I forget what it is, sorry. Huw Powell 00:49, 23 April 2011 (EDT)

Infobox[edit]

The "habitat" bit seems to have gone a bit crazy on the fish infoboxes? Or is it just me? --Cat 07:18, 30 July 2011 (CDT)

Fixed --Brian 16:47, 30 July 2011 (CDT)

Spammer bots[edit]

GAH at the huge amount signing up again, any way to prevent it? Only a couple have actually posted pages (which I've deleted and banned). --Cat 07:13, 1 August 2011 (CDT)

Yes, the captcha is gone, I must have disabled it at some point on accident. Leave the pages they create (for 24hrs or so) so I can figure out why the AbuseFilter isn't catching them. Once they are gone I can't test the filters. --Brian 10:24, 1 August 2011 (CDT)
Fixed the filter, you now need 5 edits before you can add an external link. Before it was required that you have more then 10 or be more then 7 days old. --Brian 11:56, 3 August 2011 (CDT)
Also re-enabled captcha for user account creation. --Brian 12:00, 3 August 2011 (CDT)
Sweet! Is the same triggered over on VC? They're starting to do the same over there. Thanks! --Cat 15:05, 3 August 2011 (CDT)
Not yet, I will try to get to it tomorrow. As usual remind me. --Brian 08:14, 4 August 2011 (CDT)
ARGH! They've gone bonkers on VC! I'm going on holiday next week, I don't want them to delete the site where I'm away --Cat 13:38, 16 September 2011 (CDT)

Plant Data Box[edit]

Is it just me or have the size units got themselves switched around? See here Aponogeton boivinianus. It's set to cm but acting as it if its inches! You can tell a man designed it right hehehe --Cat 07:13, 18 August 2011 (CDT)

Ooops. There was never a size units, it was always height_units and width_units. size_units works now but height/width_units can override it. --Brian 20:33, 18 August 2011 (CDT)

The new Fish Profile thing[edit]

So I have been trying it out, but when I was editing an existing page and clicked save it took me to a blank white page and didn't actually finish the edit, annoying! --Cat 06:47, 2 September 2011 (CDT)

You editing a page using the form, correct? Can you repeat the error? I have noticed an error editing some pages to that have too but it was due to the content and some parsing bug I think. --Brian 10:33, 2 September 2011 (CDT)
It's done it on three unrelated pages. Existing pages with some content, moved the content into the right boxes, did select it to be a "sub" (as it doesn't say stub at the top, it says sub!), then clicked the "save" thing and it just all went blank, white page of doom! Didn't save. --Cat 17:42, 2 September 2011 (CDT)
I know its annoying, but if you do it twice do you get the WPOD again? I will check to see if there is an error in the logs. --Brian 22:32, 2 September 2011 (CDT)
Still WPOD! Just tried a small edit on this page Malapterurus electricus (which is not a stub) and still did the same thing. --Cat 07:32, 3 September 2011 (CDT)
Worked for me :( sorry dunno what is wrong. --Brian 15:56, 3 September 2011 (CDT)

Weird!! I tried it on Chrome in case it was my firefox. Instead I got "The website encountered an error while retrieving http://www.theaquariumwiki.com/index.php?title=Gramma_loreto&action=formedit. It may be down for maintenance or configured incorrectly." BAH!! --Cat 17:04, 10 September 2011 (CDT)

Mwahaha, was making up for this still not working for me! --Cat 02:29, 12 September 2011 (CDT)
Is the error shown on a wiki page or on a blank/white page? --Brian 05:04, 12 September 2011 (CDT)
Blank white page, no wiki. --Cat 15:28, 12 September 2011 (CDT)
Weird! I made one change, saved properly using this form edit, went back to make a second change, blank page of doom! --Cat 06:52, 14 September 2011 (CDT)
Should be fixed. Lemme know. --Brian 09:37, 14 September 2011 (CDT)
BAH! it's not --Cat 13:18, 15 September 2011 (CDT)
What is your ip address? http://www.whatismyip.com/ If you post your IP when it happens they can find the problem easier. --Brian 14:16, 15 September 2011 (CDT)
It does it on both my work PC and my home laptop. Both on Mozilla, not a mozilla problem is it? IP now is 62.8.120.133. --Cat 07:09, 16 September 2011 (CDT)
No, there is a server rule causes it to think somebody is trying to hack the site so it blocks it. Next time it happens post ASAP with your IP address so I can tell the admins where to look in the logs. Sorry :( --Brian 09:00, 16 September 2011 (CDT)
Did one edit fine, saved, went back to another, white screen of death. IP is 86.8.81.13. --Cat 14:15, 16 September 2011 (CDT)
This is my home IP and it's still doing the same thing, occasionally letting me submit a new page, sometimes not, not letting me edit further with the form. --Cat 09:08, 9 October 2011 (CDT)
The edits are hitting the mod_security rules because they look suspicious. When you post that this happens I let them know and they white-list the site for that rule. --Brian 08:35, 10 October 2011 (CDT)
Annnnnd in English?? hehe! --Cat 15:02, 10 October 2011 (CDT)
ARRRGH!! It managed to let me do one just fine. So I went to do another, made it all pretty, did everything, clicked save, white screen of death, damn near flipped my desk GRRR --Cat 06:58, 13 October 2011 (CDT)
Sorry missed your last response. Submitted ticket. What I mean is that the server thinks you are trying to be bad so it blocks it... I will talk to them to see what can be done to reduce this. --Brian 07:33, 13 October 2011 (CDT)
I got all of the rules disabled. If you get a white page again please post your ip asap (so I can get the date/time) --Brian 10:10, 13 October 2011 (CDT)

It did it again! Did two stub pages fine. Went to edit a full page and moved everything over, white page of death. My IP is 172.20.20.20. --Cat 06:55, 14 October 2011 (CDT)

Ticket submitted. --Brian 07:00, 14 October 2011 (CDT)

Is anyone active!?![edit]

Hello, I need your help! Some of the templates for the aquatic creatures (min/max temperature, availability, etc.) are all missing! I really need someone else to come on and help!!!! I feel like I'm the only person on this site anymore! Please fix them! Thanks!

-HalfbeakedGar September 1, 2017 16:03 PM (UCT)

  • Hey, sorry for the delay. Are we active.. kinda. Catt and I stop by from time to time to clean up. I for one just don't have the time I once had in college what with kids and all now. I noticed the broken templates a bit ago, and have been working on getting a backup copy of the wiki restored into a local instance. I think I found what I need to fill in the missing templates. I truly appreciate your efforts to fix the site. Please reach out if you have any questions. --Brian (talk) 01:31, 6 September 2017 (UTC)

Add Temperament in the fish infoboxes[edit]

Dear Brian,

I would love it, if you added a "Temperament" template for the fish infoboxes. Thanks!

- HalfbeakedGar

What are you thinking for the allowed values? --Brian (talk) 12:37, 14 September 2017 (UTC)

Questions and concerns[edit]

Oh hey, thanks!

Haven't seen you in a while! Hope all is well!

If I may, I actually have a few questions if you are able to answer them

1. I noticed some template, and category pages vanished, was it an error, or part of a renovation? 2. Is there a way to delete this page: strombud gigas? i corrected the typo so its a blank page that sticks out like a sore thumb 3.I made a redirect to the typoed page Betta foershi I made a redirect with a correct spelling Betta foerschi so people don't get confused. If all information is moved to the redirect I think the typoed page can be just deleted as well

Thank you so much for making this wiki a great place to be!

Sincere gratitude from Flushing, NYC,

Peter

11/11/17

Ok, thanks for letting me know! --peter